DNS over HTTPS 原理与实现
深度解析 RFC 8484 规范、将 DNS 二进制报文封装在 HTTP/2 / HTTP/3 中的加密传输流程。
DNS 树状查询流、TTL 缓存失效与加密 DNS 协议实现。
深度解析 RFC 8484 规范、将 DNS 二进制报文封装在 HTTP/2 / HTTP/3 中的加密传输流程。
解析 RFC 7858 规范、使用专属 853 端口在标准 TLS 管道上传输 DNS 报文的架构与应用场景。
解析 DNS 响应中的 TTL(生存时间)字段、浏览器缓存、操作系统缓存及 CDN 动态加速下的 TTL 调优。
从 RFC 1035 标准深度梳理客户端与 LocalDNS 间的递归查询,以及 LocalDNS 向上游根域的迭代查询流程。
系统梳理本地 Hosts、OS 缓存、LocalDNS 递归查询、Root 根域、TLD 顶级域到权威服务器的完整链路。